Support / FAQs / About techtown

Home Forums Archives UNIT GOES TO PROBLEM ON DISPLAY M#GR14SPTA

  • UNIT GOES TO PROBLEM ON DISPLAY M#GR14SPTA

    guest created 1 year, 7 months ago 1 Member · 2 Posts
  • guest

    Member
    February 26, 2018 at 12:00 am

    WHEN STARTED THE UNIT SHOWS 450 DEGREES FOR 5 SECONDS THEN UNIT SHOWS PROB ON DISPLAY.

    WONDERING WHAT TO LOOK FOR, UPPER ELEMENTS OHM TO 27.5 AND MAIN LOWER DECK SHOWS 15 OHMS

  • fixbear

    Member
    February 26, 2018 at 4:09 pm

    I assume that you have a Star Panni grill with double lids.  If so I need to know at what voltage it operates and precisely what you see on the display step by step. And, what is happening pyhsically.   Is one side heating normal?   As far as I know, the SPCA is 230 volt but no high limit  2300 watt.  .  Having different heater ohm readings is normal, as the bottom is a single and the top’s are split.   The cover heaters have a RTD thermister attached to the back of the plate inside the heater area.  The flexing of the covers does make a wire failure eminent at some point in time.  They also use many controllers depending on the user.   The lower element is powered from both heater relays so that a call for heat from either one will heat the lower plate.  

     

    Ohm out your thermistors at the controllers.  E1, E2 and E11, E12.  They should be the same at the same temp.  Where did you check the element resistance?   At the relays?  

     

    As far as I know, the only feedback to the controller is Time, Temp and sensor. So unless you have a programming error, you most likely have a sensor error.  Thermister or to long to heat.

     

    Charlie, here is a manual with wiring diagram to assist you.http://download.partstown.com/is-bin/intershop.static/WFS/Reedy-PartsTown-Site/-/en_US/manuals/STA-SPT_spm.pdf

Log in to reply.

Original Post
0 of 0 posts June 2018
Now