Support / FAQs / About techtown

Home Forums Archives Combitherm Ovens

  • Combitherm Ovens

    Combitherm Ovens 1 Olivero updated 1 year, 2 months ago 1 Member · 3 Posts
  • Combitherm Ovens 2

    guest

    Member
    December 7, 2018 at 12:00 am

    Alto Shaam Combitherm Steam Convection Oven

    Model:  CTP20-20G

    Serial:  1504750-000

    The call was ignition would not light, it has upper and lower ignition, electronic his, the upper ignition had an error code E89, I replaced ignition module, I ohmed out the hsi, the ohm value was suppose to be between 40-60 ohms, it was open, I replaced the ignitor and changed the flame sensor, called for heat, no error code on upper ignition, however, E86 on lower ignition, I replaced module and Ignitor on general principle, called for heat, still no burners, I called tech support, they explained how to go into set-up and look at the blowers speeds and the performance of the system, he said the combustion blowers were suppose to operate at 150 herz or in the ball part, the upper motor was at 129 herz, the lower blower was at 151 herz, the factory advised me to replace the motor, the new motor turned at the same herz, they switched me over to the head tech support guy, we went back into the set-up and he wanted to know what software the unit is running, I told him, he said that the software was out of date and to go the Alto Shaam website and download the update onto a flash drive which I did and upload it to the oven, it corrected the blower speed but still no ignition.  Does anyone have experience these ovens, I am pretty much exhausted my approaches?

  • Combitherm Ovens 2

    fixbear

    Member
    December 8, 2018 at 8:45 am

    I think you mean error code E88, not E86.  Regardless, it comes down to the basics of combustion.

     

      We all tend to forget that with the high tech ovens of today.  To have a flame, we need fuel, air, and ignition. . Controller calls for heat, Fan starts and HSI is energized.     If the HSI has proper voltage, ohms ok, and draws the proper amps, it’s hot.  Once the Hsi current drops from the resistance change of the heating process telling the controller to open the gas valve.  Or it may be just a time delay.    Do you have gas?  Is it the right pressure?   Once gas it open, flame sensor has to see it. in 5 seconds.  Do you have a correct current flow from the sensor to controller and burner to controller ground?  It’s quite common for techs to forget or overlook the ground side of the sensor.circuit.  Face it, burners do a lot of corrosion, and expansion.  Especially the mounts.   And the electron flow is not obvious to the eye, as it’s not by wires.

  • Combitherm Ovens 4

    Olivero

    Member
    December 8, 2018 at 5:12 pm

    Well, I’ve been through the hoops of “Your software is updated, that’s why your oven all of a sudden isn’t working even though it’s been working fine for the last however many months”

     

    I find it tends to be a lame excuse that rarely solves the problem. I deal mainly with Convotherm units but I get the same spiel from Tech Support, I found for ignition issues, normally it’s the igniter and it’s some sort of grounding issue so the MA is not getting back to the ignition module or there’s an intermittent failure. 

     

    What are your MA readings? That’s all that really matters, is it Hot Surface Ignition or spark ignition?

     

    The fan controls the balance and supply of primary air to the burner, that’s all it does and it changes depending on the call for heat, on Convotherm you can call for low heat or high heat and the fan spins at different speeds = more or less fuel to the burner.

     

    Try running a ground wire from the burner flange to close to the ignition module, I had that work for me once. Then I removed it and it still worked fine so it might have been coincidental to something else I changed.

     

    The ignition module rarely fails in my experience, if it’s calling for heat and the combustion fans are spinning, it is calling for heat, no doubt. Then you can check for voltage to the igniter, if it’s not getting it, it’s most likely the ignition module that has a failed relay somewhere.

    Always, always remember this. If it ran fine since startup and is now having a problem, it’s not a core problem like software or fan speed or ignition attempts, it’s something else and I’ve gone around the bend on these “solutions” but they don’t solve anything.

     

    Additionally, the fan speeds are controlled by some sort of VFD, changing the fan won’t really do much to change the hz’s, the problem is in what’s telling the fan to speed up or slow down, if it’s telling the fan to do 150 hz but it won’t go there, that’s a different story but then you would probably have a different error code.

Log in to reply.

Original Post
0 of 0 posts June 2018
Now