Support / FAQs / About techtown

Home Forums Beverage G01 Water Missing on Rancilio Classe 10 USB

Tagged: 

  • G01 Water Missing on Rancilio Classe 10 USB

     Ted updated 3 weeks, 4 days ago 3 Members · 7 Posts
  • okwestern

    Member
    September 2, 2020 at 7:29 pm

    I’m getting the Water missing error. Water capacitive board LED is red, but water is flowing into the machine.

    Machine was taken from a 400V location, and sold to a 230V location (i’ve checked the wiring, seems correct on both sides). New owner gets this error most of the time (but have had occasions where it powered just fine). We never the problem. He’s also getting W11 Check the clock.

    Could the settings have been reset? Would this cause a confusion about water level (capacitive board vs resistive rod)? Capacitive board is default according to the technicians manual.

  • okwestern

    Member
    September 2, 2020 at 7:32 pm

    Seems the same error G01 comes even when capacitive board is green (good level of water).

  • fixbear

    Member
    September 3, 2020 at 4:30 am

    What error code are you actually getting? Is it equipped with any accessories.

    Espresso machines are a bit tricky in a lot of ways. Proper install is the key. Being a used machine, it should have gone through a refurbish before install. This would have reset the memory to restart counts for service. Supply water has to be tested and properly treated and be at a predetermined pressure for correct operation. Initial installs should be done by a Rancillo tech to get the best service and life out of the machine. They tend to hold close the passwords and codes needed for that.

  • fixbear

    Member
    September 3, 2020 at 4:51 am

    BTW: GO1 means that it did not fill fast enough or the boiler is low. Check that the machine water softener is clean and you have proper water flow and pressure. This will really mess up tea temps that have to happen to blend tea water to the right temp.

  • okwestern

    Member
    September 3, 2020 at 7:37 am

    It is a mystery. Sometimes they are getting the G01 error and capacitive board level indicator is red (the electric board you can slide up and down manually on the transparent water level tube to adjust autofill level). But other times they are getting the same G01 error and level is green. What is an acceptable water line pressure?

    I serviced the machine to the best of my knowledge before I sold it. Decalcified the boiler, opened and cleaned most valves and flow meters, checked the function of each solenoid and the inputs through the technicians menu.

  • fixbear

    Member
    September 3, 2020 at 12:43 pm

    Sounds like they have it on a shared water supply and something else is using water dropping the line pressure.

  • Ted

    Member
    October 30, 2020 at 1:23 pm

    If it is a water flow/pressure issue. Have they tried to install an expansion tank with a booster pump.

    At one of my locations we have a reserve water tank that we pull from with a pressure booster. We also have to boost the pressure to the filter system otherwise it won’t refill the reservoir fast enough. Old building with very low water pressure (~20-30psi) on a good day.

Log in to reply.

Original Post
0 of 0 posts June 2018
Now