Support / FAQs / About techtown

Home Forums Everything else… IMESA DRYING ROLLER

Tagged: 

  • IMESA DRYING ROLLER

     rigersalvora updated 1 month ago 3 Members · 12 Posts
  • rigersalvora

    Member
    March 1, 2020 at 12:37 pm

    Dear All,

    Hope you are well.

    I have an IMESA MCA 150 with the EDD Timer Control Circuit. The 3 Leds stays on when the shouldn’t, also the Seven Segment Display don’t turn on.

    Unfortunately I didn’t find even a single manual on the net describing or guiding to a point.

    Would appreciate so much if anyone could give me a feedback.

    Thank you very much for your time

    Best Regards.


    Attachments:
  • nafets47

    Member
    March 1, 2020 at 4:22 pm
  • nafets47

    Member
    March 1, 2020 at 4:25 pm

    From the manual I posted it says that, that is an ignition module issue.

    I didnt go through the entire manual to verify that it is your model as there is an earlier section which breaks down model type. But for the LEDs it doesnt state which model has different LED indications so I figured its the same.

  • rigersalvora

    Member
    March 2, 2020 at 12:18 am

    Dear Nafets47,

    I thank you for your honest response.

    The machine has two working methods, gas or electricity. The gas module has been removed so only the electrical mode works. I have tried the machine with another exact Circuit and it works. So the fault lies inthe Circuit i have send. From what the guys said, the machine worked but after they carried to another place it didn’t work anymore. So I am in a quite pickle because I am measuring branch to branch of the circuit with no real direction.

    Hope I gave a good image of the case. If more information it’s needed i will provide it.

    Thank you very much.

    Best Regards

    Rigers Alvora

  • fixbear - ADK NY

    Member
    March 2, 2020 at 6:58 am

    If it was working normally before a move, then would not after it is either incorrectly wired or suffered some form of damage during the move. Chack all removable plugs to be tight after confirming that the power connections are right.

  • rigersalvora

    Member
    March 2, 2020 at 7:54 am

    Fixbear thank you for your Reply,

    I used another Circuit and it started working, so the fault lies in the Circuit i assume.

    I wished someone could find me a manual for, cause I contacted IMESA and they didn’t give me anything

    • nafets47

      Member
      March 2, 2020 at 11:14 am

      Is that manual I provided not work? Or are you looking for a parts manual?

  • rigersalvora

    Member
    March 2, 2020 at 11:54 am

    Dear Nafets47,

    No unfortunately it wasn’t the right manual. I still think that the problem lies in the electronic board. So i will try to repair it.

    Still if anyone has any suggestion i am always open.

    Thank you very much for your consideration.

    Best Regards

    • nafets47

      Member
      March 2, 2020 at 5:38 pm

      Damn. Well perhaps their tech support could be of help in providing you a service manual or trouble shooting guide.

  • fixbear - ADK NY

    Member
    March 2, 2020 at 3:54 pm

    You may want to go to Imesa and create a log in at

    https://imesa.it/en/technical-area/

  • rigersalvora

    Member
    March 2, 2020 at 5:12 pm

    To be honest fixbear, I don’t know how to create a Log-in there. 😅

    If you know, can you please guide me?

    Thank you

  • rigersalvora

    Member
    March 2, 2020 at 5:53 pm

    I already asked them. They didn’t had anything.

    I will just tinker with the board and see what will i getfrom them.

    The two LM358N get very hot. I will exchange them first and see the development.

Log in to reply.

Original Post
0 of 0 posts June 2018
Now