Support / FAQs / About techtown

Home Forums Archives Doyon JA12SL oven, fans turn on but programming displays are dark

  • Doyon JA12SL oven, fans turn on but programming displays are dark

    guest created 5 months, 2 weeks ago 1 Member · 3 Posts
  • guest

    Member
    April 30, 2019 at 12:00 am

    This is a double oven, neither display comes on

  • fixbear

    Member
    April 30, 2019 at 7:23 pm

    Sounds like a control breaker is open.  Or the low voltage is missing.

  • sessionable

    Member
    May 4, 2019 at 7:24 pm

    Thank you very much for your feedback.The electrician finished wiring the kitchen and we plugged the oven in for the first time.

    The upper oven was displaying ER 07, but after a while the display went dark.The lower oven display never did illuminate, completely dead.

    I reset both main breakers and located two small fuses in the back, both of which have power on both sides of the fuses.But no improvement. Only both fans turn on after a few seconds.

    It is interesting that the ovens seem to be completely separate systems but have the same malfunction.Any other ideas? I havent been able to find a troubleshooting procedure except this:Er07 -Zone 1 A/D overflow error-> Open sensor-> Check the InP1 parameter. Verify itmatches your sensor.

    Being a car mechanic, some of the terminology here is greek to me plus I dont know if the ER07 is related to the dead control panels.

    Harold

Log in to reply.

Original Post
0 of 0 posts June 2018
Now